Category Archives: blob-support

[witsch] my first blo[bg] entry…

here’s a quick status update on the integration work for blob support coming with zodb 3.8: after theuni’s integrated zope 2.9 with zodb 3.8 a few months ago, and limi wished for the same thing for zope 2.10, so that we can start using it with plone 3.0 (or more likely 3.1), i’ve decided to give it a try yesterday. turns out, it was pretty easy after all — just a matter of dropping in the right branches or trunks of various packages and there you go…

ok, there’s still one failing test regarding ZClasses, but the same test is failing on the regular 2.10 branch. the only difference is, that there it’s only failing when run seperately (and passing when run together with all other tests), and with zodb 3.8 it’s failing in any case… :) however, since ZClasses aren’t used in plone at all this issue is not too important at the moment.

apart from the good news is that all tests for “CMFPlone” continue to pass with the new flavour of zope 2.10 (and the ones for “plone” break in the same way ;)). on the other hand that’s not really so surprising, since plone doesn’t make use of the new blob support after all. at least not yet. so tomorrow’s more interesting question will be what happens when atcontenttypes’ file starts using it…

ps: oh, and another thing worth mentioning is that andreas jung did the same thing for zope2 trunk (think “2.11”), so now we’ve got working branches of zope 2.9, 2.10 and 2.11 with blob support